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                                                          IconLinkTM Overview
About IconLink
        Windows 3.0 introduced a new way of managing programs called the Program Manager.   
Each program or file is represented by an icon.    By double clicking on the icon, you can start
your program and optionally load your file.    However, many icon pictures that show up in 
these group windows are rather ugly or not functional.    Thus, Microsoft provided a way to 
change these icons to more colorful or more useful pictures.    In fact, with DOS applications, 
you need a way to assign an icon to an application because they all share the same DOS 
icon.

        In the first year of Windows 3.0, thousands of icons have been created.    These are 
available as freeware or shareware from many bulletin board systems across the U.S.    Now 
people are gathering large collections of icons.    However, when you have a thousand icons, 
how do you manage them?    Can you remember them individually?    Do you have to go 
through an elaborate process any time you wish to change an icon?

        IconLink is very simply the best way to manage icons.    It will catalog your icons in 
groups just as you specify.    It will automatically find all the icons on your disk no matter how
many drives you have or in what file type they are located.    If your file has multiple icons, it 
will find them all.    You can move an icon from group to group by simply dragging it.    You 
can change an icon in the Program Manager by dragging it over the entry you want to 
replace.    In addition, you can take an icon out of a program and create a separate file that 
you can edit in an icon editor.    When you change the icon on DOS program, the icon also 
will show up in Windows when you minimize an icon.    This does not happen normally when 
you change the icon in Program Manager.
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Windows is a trademark of the Microsoft Corporation.    IconLink is a trademark of PC 
Windows.



QUICK START
1.    Open File Manager and find the ICONLINK.EXE file.
2.    Size and place the File Manager window so you can also see an open Program Manager 
window.
3.    Drag the ICONLINK.EXE file to the open Program Manager window.
4.    Start IconLink by double clicking on its icon.
5.    Use the file open command to open either or both of the two libraries of 45 icons each 
shipped with IconLink.
6.    Change icons by dragging the icon from IconLink to the icon in Program Manager you 
want to change.    IconLink will take control and change that icon.
7.    To add all of the icons on your disk, pull down the Icon Menu and choose Add Icon.    Then
click on the auto button and IconLink will add all of the readable icons on your disk to a new
library.    If you have a lot of files or icons, this might take as long as five minutes.    It will go 
through your entire disk looking for icons with an .ICO or .ICN extension.    It will also go 
through all your program files, those with an .EXE or .DLL extension, and pull the icons from 
them even if there is more than one in the file.
8.    IconLink will load these icons in several groups with a maximum of 50 icons in a group.  
The program works very much like Program Manager in that you can create new groups, 
rename groups, and then just drag an icon from one group to another.    In that way, you can 
organize your icons in any way you like.
9.    Change any icons you desire by using procedures 1 through 6 above.

        While these icons will appear in the Program Manager, Windows will not recognize them 
outside the Program Manager.    Thus, when you minimize an application, the original icon 
appears.    IconLink includes a separate utility that will recognize any DOS icons that have 
been changed and will substitute this icon anywhere you minimize it.    IconLink will load 
this utility for you if the "Enable Icon Change" box is checked in the Options menu.    This 
facility is only available when you change the icon through IconLink.    We place a small 
program in the LOAD= line of your WIN.INI file.    This program will not appear on your 
desktop, but will always be active.    We believe that everyone will want this utility unless you
are really short on memory.    You can disable this program by running IconLink and 
unchecking the "Enable Icon Change" in the Options menu.
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DEMO VERSION
        If you have downloaded this file from a BBS, you have the demo version of this program. 
This demo version does not contain any of the 90 custom icons that you will receive as a 
part of the full program, nor does it have the ability to change a program's icon while it is 
minimized on the desktop, as it does in the full program.    We have limited this program to 
have only three groups of five icons each.    The groups have their names fixed and no 
other .ICM files can be opened.    
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BUYING THE PROGRAM
        If you are interested in this program, we have one of two purchase plans:

#1 - $20 + $2 shipping and handling gets you a registered version of the program.    
(California residents add sales tax of $1.54.)

#2 - $37 (California residents add sales tax of $2.59).    By choosing this plan, you will 
receive unlimited updates to the program, mailed to you automatically, for a period of two 
years (prior to their release to the general public) at no cost to you for upgrade fees or 
postage.    We will process your order immediately and personalize your copy of the program 
with your own name and address. 

Send a check or money order for $22 or $37 for the guaranteed update plan to the following 
address (California is $23.54 and $39.59 respectively):

PC Windows
P. O. Box 1017
Agoura Hills, CA    91376

      If you would like to use MasterCard or VISA, just call our toll free order line at 800-488-
5332 and the operator will be happy to place your order.    Please specify that you want 
IconLink and whether you want 5.25" or 3.5" disk size.    For technical questions or 
assistance please call at 818-991-5332.    We will process the order immediately and 
customize your copy of the program with your name and address.
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Icon Library
        IconLink features groups of up to 50 icons in separate libraries.    You can create your 
own groups, just like Program Manager, and organize your icons into categories.    Due to a 
limitation in Windows, you can only display about 200 icons at a time.    IconLink monitors 
this limit and warns you to close a window if necessary.    The fewer applications you are 
running at the same time as IconLink, the more IconLink windows you will be able to open.

        IconLink comes with about 100 custom icons for your enjoyment.    They are located in 
two libraries named Library1 and Library2.
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Change Icons in Program Manager
        Until IconLink, the only way to change icons in Program Manager was to highlight the 
icon, pull down the File/Resources menu, hit the Change Icon button, find the filename and 
enter it, and then click on OK twice.    In addition, if you had a file with multiple icons, you 
would have to scroll through that file until you reached the icon you wanted.

        Now all you have to do is arrange your screen so that both IconLink and Program 
Manager are showing and then drag the icon to the appropriate place.    It's quick and easy.    
We've even included an automatic function to search through your hard disk and find all of 
the icons in all of the files and build your libraries automatically.    You can also refresh these 
icons automatically.
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      Adding Icons
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Change Icons on Desktop
        Normally, when you change an icon in Program Manager, it is only changed in the 
Program Manager and not in the application itself.    Thus, when you run an application and 
minimize it, it uses the original icon in the program or, if it is a non-Windows program, it uses
the DOS icon from Program Manager.    When you use IconLink to change this icon, you will 
have the opportunity to also change this icon on the desktop.

        To enable this option choose the "Enable Icon Change" selection from the Options menu. 
IconLink loads a Windows utility to always look for these programs and, when one is found, 
automatically change it on your Windows desktop.    This is done in the background and 
there is nothing you have to do to make it work.    Like any other Windows application, this 
takes up a small amount of memory.    If you find that your memory is low, you can disable 
this option by unchecking the "Enable Icon Change" selection.

Related Topics
      Icon Procedures
      Demo Version



File Menu Commands
New
Adds a new group.

When you choose New, a dialog box lets you choose the name for the new group 

Related Topics
      Adding Icons to a Group
      Automatic Loading of Icons
      Creating Groups

Open
Shows a dialog box to open another icon group.    These files are identified by the ICM 
filename extension.

Related Topics
      Adding Icons to a Group
      Automatic Loading of Icons
      Arranging Group Windows

Save As
Saves a group of icons (an ICM file) under a new name.

Delete
Deletes a group of icons also known as an ICM file.

Related Topics
      Deleting Groups
      Number of Groups Open

Rename
Renames the active group.    A group may be open or minimized to be renamed

Related Topics
      Naming Groups

Exit IconLink
Close and saves all of the open group files and exits the IconLink program.



Icon Menu Commands
Add Icon

IconLink makes adding icons very simple.    You can add one icon or all the icons on your 
disk at the same time.    There are two options for adding icons - Novice and Advanced.    This
selection is changed from the Options menu when you check the "Advanced User" box.    
Both options can search your entire disk automatically.    However, the Novice selection only 
allows you to add specific icons one directory at a time while the advanced option allows you
to select any number of files on any drives or directories.    In reality, you will be probably 
using the "Auto" button most of the time so either selection is sufficient.    Remember that 
IconLink only adds color icons, not the monochrome icons found in Windows version 2.

If you are in the Novice mode, just use "Auto" or select the type of file and highlight the files 
you wish to process.    Then click on "OK".    If you are using the Advanced Option, then each 
file you select is listed in the box on the right side of the dialog box.    To delete a selected 
file, just highlight that file and click on the "Del" button.

If you would like IconLink to do all of the work, just use the "Auto" button.    IconLink will 
search through your entire disk on all fixed drives to find all of the icons not previously 
found.    Since IconLink keeps a database of all icons found, you can always update your 
icons by using the Auto button without having to worry about bringing up duplicates or 
taking an inordinate amount of time.    If more than one icon is found in a file, all of them are 
added to the open group.    If the open group reaches its 50 icon maximum, a new group will 
be started.

Related Topics
      Adding Icons to a Group
      Automatic Loading of Icons
      Creating Groups
      Group Files
      Number of Groups Open
      Options Menu

Make ICO

IconLink allows you to take any icon in any group and make that into a single ICO file.    This
enables you to edit these icons with one of the many icon editors on the market.

Delete Icon

Simply highlight the icon by clicking on it and then select Delete Icon or use the Del key. 



Options Menu
Save Icon Positions

Checking this box saves the positions of the icons as you left them.    If you don't check this 
box, all of the icons will be automatically arranged when the group is opened.

Confirm on Close File

Checking this box brings up a dialog box when you close an icon group to confirm you want 
to close that group.

Confirm on Delete Icon

Checking this box brings up a dialog box when you delete an icon to confirm you do indeed 
wish to delete that icon.

Confirm on Delete File

Checking this box brings up a dialog box when you delete an icon group to confirm that you 
really do want to delete that group.

Enable Icon Change

Checking this box loads a special program enabling IconLink to change icons on the 
Windows desktop when programs are minimized.    This program is placed in the LOAD= line 
of your WIN.INI file so that this capability is invoked every time Windows is run.    Because 
this may use added memory and system resources, you can uncheck this box if you run into 
these Windows constraints.

Advanced User

Checking this box enables the advanced features in the loading of icons.    The expanded 
dialog box will automatically appear when you choose the Icon/Add Icon command.    Most 
users will use the powerful "Auto" function of adding icons which can be accessed from 
either the Novice or Advanced modes.



Window Menu Commands
Cascade
Arranges group windows in an overlapping pattern so that the title bar of each window 
remains visible.

Related Topics
      Arranging Group Windows

Tile
Arranges group windows side by side so that all windows are visible.

Related Topics
      Arranging Group Windows

Arrange Icons
Arranges all program and group icons in rows.

Related Topics
      Arranging Icons

Close All
Closes all of the groups.

Related Topics
      Closing Active Windows

(Group Names)
Selects a group.

Related Topics
      Selecting Windows or Icons



IconLink Keys
Key(s) Function
direction keys Move among icons within a group window.
Del Deletes icon
Ctrl+F6 or Ctrl+Tab Moves among group windows and icons.
Shift+F4 Tiles the open windows.
Shift+F5 Cascades the open windows.
Ctrl+F4 Closes the active group window.
Alt+F4 Exits IconLink.



Adding Icons to a Group
To add icons to a group, pull down the Icon menu and select Add Icon.    Then choose the 
directories and types of files you want to add and choose OK.    You may want to just choose 
to add icons automatically with the AUTO    button in this dialog box.    Icons are then brought
in to a new window.    You can then move the new icon or icons to the window(s) of your 
choice.    After this process is completed, you may wish to delete the temporary icon group 
created.

Related Topics
      Arranging Icons
      Automatic Loading of Icons
      Copying Items to Another Group
      Creating Groups
      Size of Groups



Arranging Group Windows
With the Cascade and Tile commands, you can arrange all of the group windows so that 
some part of each window is visible.
To arrange all the open group windows:

*    Choose Cascade or Tile from the Window menu.
If you choose Cascade, IconLInk resizes and layers the open group windows so that each of 
their title bars is visible.
If you choose Tile, IconLink resizes and arranges the open group windows side by side in 
the available space so that each window is visible and none of the windows overlaps.

Related Topics
      Window Menu Commands



Arranging Icons
The Arrange command in the Window menu will clean up your desktop.    If an open Window 
is active, the icons will be repositioned in that window.    If a minimized group icon is 
highlighted, the group icons will be rearranged.

Related Topics
      Window Menu Commands



Closing Active Windows
To close an active window just choose the window control menu in the upper left hand corner
of that window and choose Close.    A quicker method is to just double click on the same 
corner.    When you close the application, all open windows are automatically closed.



Copying Icons to Another Group
To copy an icon to another group:
1.    Open the group window that contains the icon you want to copy.    You can leave the 
destination group an icon or open both the source and destination group windows if you 
want to place the item in a particular location when you copy it.
2.    Hold down the Control key and drag the icon from its current location to the destination 
group's icon or window.
3.    Release the mouse button and the Control key.

Related Topics
      Adding Icons to a Group
      Automatic Loading of Icons
      Deleting Groups
      Moving Icons



Creating Groups
You can create groups in IconLink in some logical fashion to help organize your icons.

To create a new group:
1.    Choose New from the File menu.
2.    Type a name of the group you want to create that will appear in the title bar.
3.    Choose OK.

IconLInk automatically creates a .ICM file for the new group, so you can just type up to 
eight letters for the new name.

Related Topics
      Adding Icons to a Group
      Automatic Loading of Icons
      Deleting Groups
      Group Files
      Naming Groups
      Size of Groups



Deleting Groups
To delete a group:
1.    Select the group icon or window.
2.    Choose Delete from the File menu.
3.    Choose Yes to remove the group.
The group and all icons in it are deleted. This may be the only place on your disk where 
these icons are stored so be careful when you do this.

Related Topics
      Creating Groups



Group Files
Group files actually contain the complete picture of the icons.    Thus, once an icon is stored 
in a group, you do not need to keep a separate icon file.    All groups end with the ICM file 
extension.

Related Topics
      Adding Icons to a Group
      Automatic Loading of Icons
      Creating Groups
      Deleting Groups
      Deleting Groups
      Making .ICO Files
      Naming Groups
      Number of Groups Open
      Size of Groups
      Using Scroll Bars



Naming Groups
Groups can be given any valid DOS filename of eight letters or less.    IconLink automatically
adds the ICM extension and places the file in the IconLink directory.    You can organize and 
rename the groups at any time.

Related Topics
      Creating Groups
      Deleting Groups
      File Menu Commands
      Group Files
      Size of Groups



Number of Groups Open
Given the limitations of Windows, only about 200 icons can be open on the desktop at one 
time.    While this is not a problem with Program Manager, you will have many more icons in 
IconLink.    IconLink will monitor this activity and display a message for you to close one or 
more group windows.

Related Topics
      Arranging Group Windows
      Deleting Groups
      Group Files
      Shrinking Group Windows to Icons
      Size of Groups



Opening Group Windows
To open a group window, just double click on the group icon you want at the bottom of the 
IconLink window.    To open a group not loaded in the window, choose the File Open 
command.

Related Topics
      Closing Active Windows
      File Menu Commands
      Number of Groups Open
      Shrinking Group Windows to Icons



Selecting Windows or Icons
In Windows, you first select a window or icon to let Windows know what you want to work 
on. The window you're working on is the active window. Once selected, commands and 
actions affect that item.

To select a window and make it active:
    *    Click anywhere inside the window except on the Minimize or Maximize buttons.    The 
window is brought to the front; its title bar is highlighted, and its scroll bars and other 
elements become visible.
    *    Press Ctrl+F6 to cycle through group windows.

To select an icon:
1.    Position the tip of the pointer on the icon.
2.    Click the left mouse button.    The icon is surrounded by a box to show that it is selected.
3.    Use the cursor keys to move to the icon you desire or click on another icon.

Related Topics
      Arranging Icons
      Deleting Icons
      Moving Icons      Opening Group Windows
      Window Menu Commands



Shrinking Group Windows
To shrink or minimize an icon just click on the downward arrow in the upper right corner of 
the window.    You can also choose the window menu in the upper left corner and choose the 
Minimize selection.

Related Topics
      Arranging Group Windows
      Closing Active Windows
      Number of Groups Open
      Selecting Windows or Icons
      Size of Groups



Size of Groups
Groups are limited to 50 icons each.

Related Topics
      Adding Icons to a Group
      Automatic Loading of Icons
      Arranging Group Windows
      Closing Active Windows
      Creating Groups
      Number of Groups Open



Using Scroll Bars
Some windows and dialog boxes have scroll bars you can use to view text that requires more
than the available space.    Remember that you can scroll in all four directions.    The more 
group windows you have on the desktop at a time, the more scrolling that will be necessary.

To scroll Do this
Up or down one line Click one of the scroll arrows.
Up or down one window Click the scroll bar on either side of the scroll box
Continuously Hold the mouse button on one of the scroll arrows
To any position Drag the scroll box to a place you choose.

Related Topics
      Arranging Group Windows
      Moving Icons      Selecting Windows or Icons
      Size of Groups



Automatic Loading of Icons
IconLink will search your entire disk for icons.    Just choose the Icon/Add Icon selection and 
select the file type on the right hand side of the dialog box.    Then choose Auto and let 
IconLink do the work for you.    Since each group is limited to 50 icons, IconLink will create 
new groups as necessary.

Related Topics
      Adding Icons to a Group
      Creating Groups
      Icon Menu Commands
      Size of Groups
      Number of Groups Open



Adding Icons
Icons can be added to IconLink either singly or with the entire disk at a time.    To add icons 
singly, choose the Icon/Add Icon menu and select the file type in the left hand side of the 
dialog box.    Then choose the proper directory and file in the dialog boxes below.    When you
double click on the filename or choose OK, the icon is added.

Related Topics
      Automatic Loading of Icons
      Creating Groups
      Icon Menu Commands
      Size of Groups
      Number of Groups Open



Changing Icons in Program Manager
IconLink makes changing icons in the Program Manager easy.    Just position IconLink so 
the group window with the icon you want to place is visible.    Then make sure that the 
Program Manager window with the icon you want to replace is visible.    Then click and hold 
the left mouse button and drag the icon from IconLink to a point directly over the icon you 
want to change.    When you drag the icon, a box will appear to help you position the cursor.   
When the box is directly over the icon you wish to change in Program Manager, just release 
the left mouse button.    IconLink then takes control of Program Manager and changes the 
icon for you.

Related Topics
      Change Icons on Desktop      Adding Icons to a Group
      Arranging Group Windows
      Icon Files
      Number of Groups Open
      Size of Groups
      Using Scroll Bars



Deleting Icons
Deleting an icon from a group does not remove the ICO file from the IconLink directory.
To delete an icon from a group:
1.    Open the group window that contains the icon you want to delete.
2.    Select the icon.
3.    Choose Delete from the File menu.
4.    Choose Yes.

Related Topics
      Adding Icons to a Group
      Moving Icons
      Selecting Windows or Icons



Drawing Icons
IconLink does not include an icon drawing program at this time.    There are several 
shareware and commercial icon drawing programs available.

Related Topics
      Editing Icons
      Making .ICO Files



Editing Icons
IconLink does not include an icon editing program at this time.    There are several 
shareware and commercial icon drawing programs available.    However, IconLink can take 
any icon in any group and make an ICO file from it.    This file is then editable with an icon 
drawing program.

Related Topics
      Making .ICO Files



Icon Files
Icon files are small paintings (actually 32 by 32 dots) on your desktop.    It is important that 
Program Manager know where these files are because if you make a system or name 
change, it searches for this icon.    For this reason, every time you change an icon in Program
Manager, an ICO file is created in the IconLink directory.    Because we cannot know if this 
icon is used multiple times, IconLink cannot delete these ICO files when an a Program 
Manager entry is changed or deleted.    These files are small, however, and will not need to 
be purged for a long time.    You can delete all icons on your disk outside of the IconLink 
directory because they will appear in the IconLink group files.

Related Topics
      Making .ICO Files
      Adding Icons to a Group
      Automatic Loading of Icons



Making .ICO Files
If you wish to edit an icon or to give a single icon to someone else, you can make an ICO file 
from any icon in the IconLink group file.    Just select the icon and then choose the 
Icon/Make ICO menu selection.

Related Topics
      Drawing Icons
      Editing Icons
      Icon Files



Moving Icons
Moving Icons to Another Group
To move an icon to another group:

1.    Open the group window that contains the icon you want to move.
2.    Drag the icon to the destination group's window.
3.    Release the mouse button when the icon is in place

Related Topics
      Adding Icons to a Group
      Deleting Icons
      Copying Icons to Another Group



About PC Windows
PC Windows is a West Coast company that began as a computer store selling graphical user 
interfaces and hardware to small companies and individuals.    This company then joined 
forces with Gordian Systems, a programming and systems company, to develop Windows 
utilities.    We hope you enjoy IconLink.

Other Topics
      Overview
      Commands
      Library Procedures
      Icon Procedures
      Demo Version


